Consultor Eletrônico



Kbase P130018: Database cannot be managed using Progress Explorer.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/01/2009
Status: Unverified

SYMPTOM(s):

Error 9149: Time out limit (<max_wait> seconds) exceeded waiting for ACK.

Not all databases are shown as running in Progress Explorer.

Those databases can not be managed (started or stopped) by Progress Explorer.

Those databases do not respond using the dbman.

Those databases can be stopped and restarted manually.

Those databases can be connected to through the application.

Before registration to the AdminServer succeeds several time out messages can be seen in the DB logfiles


FACT(s) (Environment):

After starting AdminServer, all databases with 'autostart' start and all
get registered to the AdminServer(according to log files) eventually.

This behavior is observed when trying to start all the databases at the same time.
This behavior is not observed when trying to start the databases one after another.
Customer recently migrated some of the DBs from v9 to v10, problem was not observed in v9 before migration

Progress 9.1E04 Service Pack and OpenEdge 10.1B03 Service Pack installed on the same machine.
Problem is only observed with the v10 DBs

The DBs are hosted on a ViM Ware Virtual Machine which was not adjusted after the migration:

+ Windows Server 2003 SP2

+ Dual Core Intel Xeon 3.2 GHz CPU

+ 2 GB ram

+ hi-speed SAN disks, temporary files located on 'local' drive

Problem cannot be observed on the production machine which is not a Virtual Machine:

+ Windows Server 2003 SP2

+ Dual Processor Dual Core Intel Xeon 3.4 GHz CPU

+ 8 GB ram

+ hi-speed SAN disks, temporary files located on local drive


Windows 2003
OpenEdge 10.1B
OpenEdge Category: Database

CAUSE:

System resource issue


FIX:

Move to a more powerful virtual machine.