Kbase P109198: Error trying to view tables in Crystal Reports 11 (XI) using JDBC connection to a Progress database
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  4/3/2008 |
|
Status: Unverified
FACT(s) (Environment):
OpenEdge 10.x
Crystal Reports 11 (XI)
Windows
SYMPTOM(s):
Error message appears when attempting to expand database schemas to access tables
Crystal Reports
Database Connector Error: 'Exception: [Error Message:]null'
Connecting to database using Crystal Reports 11 (XI)
Using Progress' JDBC driver to establish the connection
Problem affects both PUB and SYSPROGRESS schemas
Error prevents access to tables, views and stored procedures
Creating a Command (free-form query) works as expected; SQL statement is executed and data returned
CRConfig.xml file for Crystal Reports 11 (XI) has been configured correctly (CLASSPATH is correct, JDBC URL is correct, etc.)
Changing the <Option> parameter in CRConfig.xml to "Yes" causes the error message to change
Database Connector Error: 'SQL Exception: [SQL State:] HY090 [Error Message:] [JDBC OpenEdge Driver]: The qualifier 'PUB' was larger than SQL_MAX_QUALIFIER_LEN from SQLGetInfo(0).'
Schemas are accessible using the same JDBC driver in the third-party tool DbVisualizer 4.x
CAUSE:
This is a bug in how Crystal Reports XI handles the Progress OpenEdge JDBC driver
FIX:
This issue has been fixed by Business Objects. Refer to Business Objects solution c2019464 for more information.
The patch is available for download here:
ftp://ftp1.businessobjects.com/outgoing/CHF/commonXIwin_chf.zip