Kbase P129538: ODBC connection fails with error: "Server rejects connection on attach"
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  17/12/2008 |
|
Status: Unverified
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.x
SYMPTOM(s):
ODBC connection fails with error:
[DataDirect][ODBC OPENEDGE driver][OPENEDGE]Server rejects connection on attach.
Test connect from client fails with error.
CAUSE:
Incorrect user/password provided.
FIX:
Use correct user and password.
Note that SQL92 login authentication will use one of two possible methods to verify user authenticity.
1) If no entries have been defined in the database user table (_user) then the database is queried to see what user created the database. The credentials of the user attempting connection are checked to see if the user is supplying the correct user and password of the user that created the database.
To perform this check, operating system libraries are used to interrogate the OS security system.
If the username and password are not correct based on the operating system, the user credentials supplied are considered invalid.
2) If any entries have been defined, i.e. if even one user has been added to the user table (_user) in the database, then from that point forward only the _user table will be used to authenticate logins.