Kbase P129438: Error "Unable to obtain list of tables from the data source" when connecting via ODBC from MS Excel
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/5/2008 |
|
Status: Unverified
FACT(s) (Environment):
OpenEdge 10.1B
Windows
SYMPTOM(s):
MS Excel
Unable to import data into MS Excel
MS Excel displays an error when trying to display a list of tables:
Unable to obtain list of tables from the data source
MS Excel just returns to Data Connection Wizard
Data is imported correctly using OpenEdge 10.1A ODBC driver
CAUSE:
DataDirect ODBC driver bug# DEF0000737 causes problem
FIX:
Option #1
Upgrade to OpenEdge 10.1C or later
Option #2
DataDirect Solution 2479741FF provides the following workaround:
Use the Registry editor: 'regedit.exe'. (Improper use of this tool may corrupt your system) to set the key value/pair WorkArounds=2
If using an USER ODBC Data Source, select the following registry key: HKEY_CURRENT_USER\Software\ODBC\OBDC.INI\<yourdsnname>
If using a SYSTEM ODBC Data Source, select the following registry key: HKEY_LOCAL_COMPUTER\Software\ODBC\OBDC.INI\<yourdsnname>.
Right click, and select 'Edit', 'New', 'String Value'. Set the name of the new string to 'WorkArounds' and set its value to 2.
When using a FILE ODBC Data Source, add the following line to your .dsn file:
WorkArounds=2