Kbase P129256: Error 1422 after backing out of online idxactivate
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  17/07/2008 |
|
Status: Verified
SYMPTOM(s):
Error 1422 after online idxactivate
idxactivate finds existing connections to the related table
Activating Index <indexname> at Database timestamp <timestamp>. (12811)
Connections with timestamps older than <dbtimestamp> exist. (13246)
Do you wish to continue waiting..... Type y to continue (y
). (13247)
Accessing the table after "n" is selected to the 13247 prompt results in error 1422
SYSTEM ERROR: Index in for recid could not be deleted. (1422)
Data Dictionary still shows the index as Inactive
FACT(s) (Environment):
OpenEdge 10.1x
CAUSE:
When (n) is selected to backout the idxactivate, the active flag on the index remains set. Subsequence access to the table results in error 1422 as the indexes themselves have not been built.
CAUSE:
Bug# OE00149138
FIX:
Upgrade to OpenEdge 10.1C where the active flag is no longer set.
Workaround#1:
delete the index
create index again inactive
ensure no clients connected
start idxactivate
allow clients to connect again
Workaround#2:
delete the index
create index again inactive
- then when prompted:
Do you wish to continue waiting..... Type y to continue (y
). (13247)
- select (y), as soon as all the relevant clients are out of the database, the idxactivate proceeds;
Index Activate: Index <indexname> No. <indexnum> - <keycount>keys added. (13244)
Index Activate: Index <indexname> No. <indexnum> - <keycount>keys processed. (13245)