Consultor Eletrônico



Kbase P129184: Error 12036 occurs when trying to start database from Progress Explorer even though port is unused
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   20/03/2008
Status: Unverified

FACT(s) (Environment):

Windows

SYMPTOM(s):

Unable to start new database added in Progress Explorer

Progress Explorer returns an error

Error in startup of database <Hostname>:<AdminServer Port>:<Database>. Message:
HH:MM:SS BROKER ** This process terminated with exit code 1. (8619) (JUNMsg024)

Error in startup of database localhost:20931:Sports2000. Message:
HH:MM:SS BROKER ** This process terminated with exit code 1. (8619) (JUNMsg024)

Database is not started

Database log file reports error 12036

The port <n> is already in use. (12036)

Port specified for -S does not appear to be in use (not listed by port checking software, such as Microsoft's Port Reporter service)

Port specified for -S is below 3000

Database can be started successfully from Progress Explorer when using a higher port number (for example, 9999)

Database can be started successfully from Progress Explorer after rebooting the server

Database can be started successfully from Progress Explorer after leaving the server alone for several hours

CAUSE:

The exact cause is unknown at the time of this writing but the issue appears to be related to the use of port numbers less that 3000. Progress Software does not recommend the use of port number less than 3000 as this range is typically used by operating system processes.

FIX:

Use a port number above 3000 for -S and outside of the -minport -maxport range for the database(s)