Kbase P129133: Why do I see columns listed as attributes for Index Relevancy choices that do not have an attribute
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  23/10/2008 |
|
Status: Unverified
SYMPTOM(s):
Why do I see columns listed as attributes for Index Relevancy choices that do not have an attribute query and were not defined as attributes in my e-commerce dictionary?
FACT(s) (Environment):
EasyAsk 9.6
EasyAsk 9.7
EasyAsk 10.1
CAUSE:
Attributes can be pulled from the database with an attribute query or defined using the Merchandising Manager or Studio. They also can be established by using the dictionary editor and setting the column property SUGGESTION. However, using SUGGESTION is not the e-commerce method for creating attributes as it stores the attributes in the dictionary rather than the index. This is needed for non e-commerce solutions since they do not have an index.
FIX:
Use the dictionary editor and verify that no columns have SUGGESTION checked in the property settings. After making changes, save the dictionary and rebuild the index.