Kbase P128980: Cannot add a new record to an existing table without receiving errors - database corrupted
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/11/2009 |
|
Status: Verified
SYMPTOM(s):
Cannot add a new record to an existing table without receiving errors.
SYSTEM ERROR: Index in for recid could not be deleted. (1422)
SYSTEM ERROR: Index req_key in required for recid 100098 could not be deleted. (1422)
SYSTEM ERROR: Cannot read field from record, not enough fields. (450)
SYSTEM ERROR: Cannot read field 9 from record, not enough fields. (450)
SYSTEM ERROR: Failed to extract field <field-num> from <file-name> record (table <table-num>) with recid <RECID>. (3191)
SYSTEM ERROR: Failed to extract field 9 from b-materials record (table 36) with recid 1222. (3191)
lkrel errors also appearing in the database log file for non related events.
SYSTEM ERROR: lkrels record <recid> not locked. (435)
IDXFIX terminates on second scan attempt with an lkrels error.
DBRPR detected errors for the table where record was being added.
Invalid index blocks found. Reason: Dbkey count does not match header
Scan past last field error also detected with a record in a different table.
DBRPR options to scan and repair the database were ran successfully.
IDXBUILD errors with Cluster 0 already on chain message.
IDXBUILD then terminated with a 210 error.
SYSTEM ERROR: Attempt to read block <number> which does not exist. (210)
SYSTEM ERROR: Attempt to read block 0 which does not exist. (210)
FACT(s) (Environment):
Can add records to other tables without error.
IDXFIX found no errors with scanning indexes.
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
CAUSE:
Database is corrupted.
FIX:
Dump and load database to address damaged index blocks as well as corrupted record. Upgrade to latest OpenEdge Service Pack to ensure all known defects have been addresseed