Consultor Eletrônico



Kbase P128944: Trend Micro Antivirus package causing excessive delay when disconnecting from Database on Windows.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   02/07/2009
Status: Verified

SYMPTOM(s):

Trend Micro Antivirus package causing excessive delay when disconnecting from Database on Windows.

Disconnection of remote client takes 5 minutes.

Disconnection from database takes a long time.

Disconnection of shared memory client takes 5 minutes.

Noticed that creation of sports2000 database took excessive amount of time.

FACT(s) (Environment):

Windows
Progress 9.x
OpenEdge 10.x

CAUSE:

Trend Micro Antivirus is actively scanning memory and is reviewing the actions of the Progress / OpenEdge process as it is disconnecting from the database. This is causing the disconnect phase to be slowed.

The problem is caused by Virus Pattern 995 and is recognized as an issue by Trend Micro - http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-1036858&id=EN-1036858

FIX:

To fix the issue, please apply Trend Micro pattern file 4.997.00 or greater. This pattern file has been uploaded to the Trend Micro ActiveUpdate server.