Kbase P128908: Unable to connect via JDBC or ODBC to database started with Progress Explorer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  4/27/2009 |
|
Status: Verified
SYMPTOM(s):
Unable to connect via ODBC to database broker
Database started with AdminService / Progress Explorer
ODBC Test Connect generates errors and connection fails
[DataDirect][ODBC Progress OpenEdge Wire Protocol driver]Connection refused. Verify Host Name and Port Number.
[DataDirect][ODBC Progress OpenEdge Wire Protocol driver]Socket closed.
[DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OPENEDGE]Broker rejects connection.
ODBC DSN is correctly configured to use a Port Number and not a Service Name
Connection with SQLEXP (JDBC) from PROENV prompt fails
Error in SQLExplorer.Exceptions reads:
Exception at <date/time>: java.sql.SQLException
Message (throw): ### Connect stack trace. ###
Message (excp): [DataDirect][OpenEdge JDBC Driver]Error establishing socket to host and port: <hostname>:<port number>. Reason: Connection refused: connect
Stack Trace:
java.sql.SQLException: [DataDirect][OpenEdge JDBC Driver]Error establishing socket to host and port: <hostname>:<port number>. Reason: Connection refused: connect
at com.ddtek.jdbc.base.BaseExceptions.createException(Unknown Source)
at com.ddtek.jdbc.base.BaseExceptions.getException(Unknown Source)
at com.ddtek.jdbc.openedge.OpenEdgeImplConnection.open(Unknown Source)
at com.ddtek.jdbc.base.BaseConnection.connect(Unknown Source)
at com.ddtek.jdbc.base.BaseConnection.setupImplConnection(Unknown Source)
at com.ddtek.jdbc.base.BaseConnection.open(Unknown Source)
at com.ddtek.jdbc.base.BaseDriver.connect(Unknown Source)
at java.sql.DriverManager.getConnection(DriverManager.java:512)
at java.sql.DriverManager.getConnection(DriverManager.java:171)
at com.progress.sql.explorer.SQLConnectServer.call(SQLConnectServer.java:37)
at com.progress.common.rmiregistry.TryIt.run(TryIt.java:186)
Primary (ABL) and Secondary (SQL) configurations added to Progress Explorer
ABL / 4GL connections work correctly
ABL configuration is started
SQL configuration is not started
FACT(s) (Environment):
OpenEdge Server Technology Category: AdminServer
OpenEdge 10.1x
Windows
CAUSE:
It is possible to create multiple Configurations for a single database in Progress Explorer but only one Configuration can run at a time. The Configuration designed to accept SQL connections will never start if the ABL Configuration is already running. The connection errors occur because there is no broker running on the specified port.
FIX:
Configure a new ServerGroup of the SQL secondary broker.
In Progress Explorer, right-click on defaultConfiguration (or other database configuration) and select New to create a new ServerGroup.