Kbase P128902: Error "Server rejects connection on attach" when trying to connect via ODBC to database started with
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/11/2008 |
|
Status: Unverified
SYMPTOM(s):
Unable to connect via ODBC to database broker
Database started with AdminService / Progress Explorer
ODBC Test Connect generates an error and connection fails
[DataDirect][ODBC OPENEDGE driver][OPENEDGE]Server rejects connection on attach.
Primary (ABL) and Secondary (SQL) brokers configured in Progress Explorer
ABL / 4GL connections work correctly
Explicitly setting DLC environment variable on the system
ODBC Test Connect succeeds when database is started via PROENV and PROSERVE
Changing AdminService user to local Administrator has no effect
Re-ordering / renaming brokers to ensure that SQL broker starts first has no effect
Modifying default port ranges to higher values has no effect
Windows DEP settings are correct
FACT(s) (Environment):
OpenEdge 10.1x
Windows
CAUSE:
Path used in DLC environment variable was incorrect, pointing to the wrong / non-existent location; the environment variable overrode the correct path contained in the Registry. ODBC connection worked correctly when the database was started from the PROENV script because the PROENV resets the DLC environment variable for its session.
FIX:
Remove the DLC environment variable or enter the correct path to DLC.
Stop the databases running from Progress Explorer.
Stop and restart the AdminService.