Consultor Eletrônico



Kbase P127577: Error 1252 connecting Oracle
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   9/9/2008
Status: Unverified

SYMPTOM(s):

Error 1252 connecting Oracle

ORACLE error see "ORACLE Error Messages and Codes Manual". (1252)

Oracle error ora-01012 : not logged on

AdminServer running as a service on Windows.

WebSpeed/AppServer can not connect to Oracle

Prowin32 might be able to connect to oracle in the same machine

SqlNet used to connect Oracle

SqlNet configured to use NTS to validate logon information

FACT(s) (Environment):

Progress 9.x
OpenEdge 10.x
WebSpeed 3.x
Oracle
Windows 32 Intel

CAUSE:

As AdminServer is running as service under Windows, this services has its own login/password, that might be different from the one logged for desktop activities, and if this user used to login AdminServer is not authorized to connect Oracle using NTS, either WebSpeed/AppServer may fail to connect Oracle.

FIX:

To fix it:
1 - Add this user to the ones authorized to connect Oracle.
2 - Modify SqlNet to use an standard model user/password provided the application, doing the following steps:
a) Open your sqlnet.ora file located in your oracle installation
b) add comment or remove the line: SQLNET.AUTHENTICATION_SERVICES= (NTS).