Kbase P127246: Date and timestamp mismatch errors - OS copy of a database and extent location not updated
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/10/2009 |
|
Status: Verified
SYMPTOM(s):
Production database cannot be started with proserve command.
Last open date mismatch. (9215)
Control Area has a last open date of <time-stamp>. (9217)
Probable backup/restore error. (605)
Database had been running fine until the database was shutdown and then tried to be restarted.
Cannot truncate the bi file.
FACT(s) (Environment):
All Supported Operating Systems
Progress/OpenEdge Versions
CHANGE:
A copy of the production database was restored into a different directory on the same machine. Prostrct repair was used on the copy of the database to reflect where the extents for the copy of the database resided.
CAUSE:
The copy of the database that was placed into a different directory had some extents that were still pointing to the original location. When the prostrct repair was issued the data and time stamp of these extents were altered.
FIX:
Restore the database from a backup.
or
Use prostrct unlock command on the database to gain access to the database. Run reports against the database to address any logical corruption that may have occurred when the database was unlocked. Can use proutil dbname -C dbrpr to scan blocks and records for all areas to ensure no physical corruption. To validate indexes use: proutil dbname -C idxfix. To ensure no meta schema corruption, would recommend a dump and load of the database.