Kbase P127013: Getting error (db: 8224, pro: 8342). (44) opening database with prowin32 single user session after
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  19/11/2007 |
|
Status: Unverified
FACT(s) (Environment):
Windows
OpenEdge 10.1B
SYMPTOM(s):
Getting error (db: 8224, pro: 8342). (44) opening database with prowin32 single user session after restoring database.
** Database has the wrong version number. (db: 8224, pro: 8342). (44)
CAUSE:
The exact cause is unknown.
In at least one incident corruption to the <database>.db file was identified.
FIX:
Backup the database using operating system copy or backup program.
If you have an up-to-date copy of the <database>.st file you may use it with the following steps.
Delete the <database>.db file.
Use prostrct builddb to correct the corruption.
Example:
prostrct build <database> <up-to-date copy of database>.st
If there is no current copy of the .st file then create one and follow the steps above.
Refer to the Database Administration Manual for information regarding .st file syntax.