Kbase P126935: PURG locks remain in database over time for AppServer agent connections
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  18/09/2009 |
|
Status: Verified
SYMPTOM(s):
PURG locks remain in database over time for AppServer agent connections
Lock table is growing over time
Promon shows an increasing number of locks in the PURG chain
Locks carry the NOLK flag
Locks disappear only when the AppServer agents are shut down or restarted
Locks stay when user sessions disconnect from running AppServer agent
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.1A
OpenEdge 10.1B
CAUSE:
Bug# OE00160855
CAUSE:
As described in solution P124618 , PURG locks are a normal feature of the product starting on OpenEdge 10.1A. However, in the case of the AppServer the logic in charge of automatically removing the PURG locks when the agent finishes handling a specific client session is not functional.
FIX:
Upgrade to OpenEdge 10.1C or later.