Kbase 18072: Winframe, Shared Memory Considerations And Configuration
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/10/2008 |
|
Status: Unverified
SYMPTOM(s):
There is no server for database <dbname>. (1423)
CAUSE:
Since increased performance can be expected when connecting a client to Shared Memory, many users are opting for this setup. But the Shared Memory will not be available in all cases. This is a Winframe problem which Citrix, at this writing, is looking into.
FIX:
If on a Winframe Client running Progress the following error message
appears, check how the server was started.
There is no server for database <dbname>. (1423)
If the database was started with an icon as follows:
C:\DLC\_Mprosrv.exe Databasename
then no Shared Memory is created. This can be checked with Winobj or any other program that is able to view Shared Memory. The user that is logged in has no influence on the Shared Memory creation so starting the server as Administrator will not help.
If the database is started from ProControl and ProService is assigned to a specific user, then again the Shared Memory is not created. The Shared Memory is only available for this single user and using the same login from another client will not give access.
The only way to start the server so that Shared Memory can be used is to let ProService be owned by the LOCALSYSTEM account and have the environment setting ACCESS=all set in ProControl's environment folder. The SYSTEM also needs to have Full Control on the directories where the databases are. This must be set from Filemanager.
If any problem arises when connecting to Shared Memory, the first thing to check is that the Shared Memory has been created. Use any program that can view NT Objects and there should be entries resembling:
sharemem.c.work.sports.0