Kbase P126649: AdminServer will not start after changing IP address.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  7/1/2009 |
|
Status: Verified
SYMPTOM(s):
AdminServer will not start after changing IP address.
Exception listed in ads0.exp file:
Exception at Wed Oct 24 11:32:01 EDT 2007: java.rmi.ConnectException
Message (throw): RegistryManager: PrimaryRegistryManager - Could not bind name Chimera to object com.progress.chimera.adminserver.NonNTAdminServer[RemoteStub [ref: [endpoint:[191.168.0.2:32788](local),objID:[0]]]]
Message (excp): Connection refused to host: myhost; nested exception is:
java.net.ConnectException: Connection timed out
Exception at Wed Oct 24 11:32:01 EDT 2007: java.rmi.RemoteException
Message (throw): Failed to register admin server.
Message (excp): Bind of "Chimera" failed
Stack Trace:
java.rmi.RemoteException: Bind of "Chimera" failed
FACT(s) (Environment):
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
CAUSE:
IP Address of machine failed because entry in the hosts file was not updated to match.
This caused an address conflict since attempts to start the AdminServer attempted to bind it to an IP which was not valid for the current system.
FIX:
Correct the IP address listing within the hosts file of the machine to correspond to the current IP address of the machine.