Kbase P126557: Can not connect to SQL server database using system DSN
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  22/03/2010 |
|
Status: Verified
SYMPTOM(s):
Can not connect to SQL server database
Error connecting to SQL server database
IM002: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified Failed to connect to the MSS database.
Using system DSN
Can connect to the same database via user DSN
User belongs to admin group of the machine
FACT(s) (Environment):
MS SQL DataServer
Progress 9.x
OpenEdge 10.x
CAUSE:
The exact cause is unknown at the time of writing. It is possibly related to user permissions accessing a system DSN
FIX:
Use user DSN. This imposes no problem with this specific configuration. The user is using unified data server broker which is started under the same user that created the user DSN. The servers spawned by the unified broker will run under this user account thus has no problem accessing a user DSN