Consultor Eletrônico



Kbase P122040: WebSpeed and AppServer brokers frequently unregister from NameServer
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/25/2010
Status: Verified

SYMPTOM(s):

WebSpeed and AppServer brokers frequently unregister from NameServer

Error 8210 is apparent in the NameServer log

Unregistering Broker <Broker Name>. (8210)

Error 8550 is seen on the broker log file

No response received to keep-alive message sent to NameServer. (8550)

Progress 9.1D08 and OE10.1A are installed on the same machine


Two NameServers form both installations are running on the same machine but on a different ports

Multiple brokers are running from both installations


All the above broker are running on the same machine

The problem is apparent only with OE10.1A brokers

Increasing the brokerKeepAliveTimeout to 60 did not resolve the issue

CAUSE:

The exact cause is unknown at the time of this writing

FIX:

Use only one NameServer for all the version 9 and the OpenEdge broker.

To use only one NameServer, edit one of the ubroker.properties file on the same machine as shown below below and restart the AdminServer and the brokers.

[NameServer.NS1]
autoStart=0
environment=NS1
location=remote
hostname=localhost
portNumber=5162
srvrLogFile=$WRKDIR/NS1.ns.log