Consultor Eletrônico



Kbase P126531: Can not add one rule of larger Rule Set in OpenEdge Management.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   24/10/2007
Status: Unverified

FACT(s) (Environment):

OpenEdge Fathom Category: Management
All Supported Operating Systems
OpenEdge Management

SYMPTOM(s):

Can not add one rule of larger Rule Set in OpenEdge Management.

Clicking on save rule appears to save but the rule doesn't appear in list of rules defined.

CAUSE:

The fathom.odb database may have become corrupted.

FIX:

If the rule or rule set is one of the Standard Rule Sets supplied by Progress then the template for the rule set will be located in $OEMANAGE/templates.

Use the following steps to attempt to repair the fathom.odb.
Within the OpenEdge Management Console
1) Click on the Library tab
2) Expand the Rulesets listing in the left pane
3) Expand the relevant section the damaged rule set is listed under (e.g. AppServer; Database; Logfile; NameServer or Webspeed)
4) Select the damaged ruleset
5) If there is an option to delete the ruleset, choose Delete in the right pane
Note: If the ruleset or any portion is in use for a job or monitor it will not be possible to delete it. It will be necessary to remove the rule(s) or rule set from any active task or monitor defined.
6) Select the parent section in the left pane (e.g. AppServer; Database; Logfile; NameServer or Webspeed)
7) Select the Library button in the right pane.
8) Select Import from the Library button choices
9) Supply the explicit path to the template ruleset.
Example:
c:\dlc31b\templates\defaultOEReplLogFileRuleSets.xml