Kbase P126376: Error 293 with adm2 files when running WebClient sample SportsPro application
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  22/01/2009 |
|
Status: Verified
SYMPTOM(s):
Error 293 with adm2 files when running WebClient sample SportsPro application
WebClient application produces errors that it cannot find three adm2 files
** "adm2/dataquery.p was not found (293)
dataquery.p was not found (293)
** "adm2/dataextapi.p was not found (293)
dataextapi.p was not found (293)
** "adm2/lookupfield.r was not found (293)
lookupfield.p was not found (293)
WebClient sportspro.wcp file has some files omitted from the Main component
FACT(s) (Environment):
Windows
OpenEdge 10.0x
OpenEdge 10.1A
OpenEdge 10.1B
CAUSE:
Bug# OE00159745
CAUSE:
Some ADM2 files are different between Progress V9 and OpenEdge 10. These three missing files weren't required (and didn't exist) in Progress V9, but do exist and are required in OpenEdge 10. They were accidentally omitted from the OpenEdge 10 sportspro.wcp file.
FIX:
Workaround:
Open the sportspro.wcp file and add the missing files to the "main" component within the Component tab, then re-generate the WebClient application.