Kbase P126332: Users unable to connect to database. Getting error 5291.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  7/1/2009 |
|
Status: Verified
SYMPTOM(s):
Users unable to connect to database. Getting error 5291.
You have attempted to connect to a database with too many
users connected to it. Retry the connection later,
or increase -n on the server. (5291)
Other error listed in database log file
[2007/10/11@11:12:57.773-0700] P-5219 T--1220681600 I SQLSERV 1: (43) ** Cannot find or open file /tmp/sports2000.b1, errno = 13.
Other error listed in database log file
[2007/10/11@12:09:10.802-0700] P-21438 T-0 I BROKER 0: (-----) enssbrocon: child exited with 2, err=9
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.x
CAUSE:
Permissions on the files of the database are not correct for all Progress / OpenEdge executables and processes to touch all the database files.
This may have occurred after the database was started.
FIX:
To correct this problem the database must be stopped.
The permissions on all the database files must be checked and any files with insufficient permissions, ownership and group must be changed.
The database may be restarted and normal functionality should be restored.