Consultor Eletrônico



Kbase P126251: Cannot restore 10.1B02 probkup in 10.1B01
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   21/01/2008
Status: Verified

FACT(s) (Environment):

OpenEdge 10.1B01 Service Pack
OpenEdge 10.1B02 Service Pack

SYMPTOM(s):

Cannot restore 10.1B02 probkup in 10.1B01

Unable to complete version 177 restore with a version 178 backup

Large files are not enabled on the database

restoring a 10.1B01 probkup in 10.1B02 suceeds

CAUSE:

The increment in version number in 10.1B02 is intentional as there are changes in this Service Pack that rely on a changed structure.

FIX:

Apply the OpenEdge 10.1B Service Pack 02 to the environment the probkup needs restoring to.

Alternatively:

Important NOTE: This work around is safe for all platforms EXCEPT Linux.
Please refer to Solution P123608, "Unable to restore probkups between 32-bit and 64-bit Linux installations".

- obtain the _dbtutil.exe from another environment where the OpenEdge 10.1B02 Service Pack has already been installed (eg: from the environment where the probkup was originally taken)
- rename the current 10.1B01 _dbutil.exe (temporarily)
- place the 10.1B02 _dbutil.exe (temporarily) in %DLC%\bin
- restore the 10.1B02 backup with prorest utility
- rename the 10.1B02 _dbutil.exe in %DLC%\bin
- rename the original 10.1B01 _dbutil.exe in %DLC%\bin