Kbase P125549: Remote 4GL client hangs with error 1280
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/15/2010 |
|
Status: Verified
SYMPTOM(s):
Remote 4GL client hangs
Remote 4GL clients hang
The remote clients session hang initially, then finally was able to make connections
Error 1280 in database log file
Connection timed out on socket=<n> for usernum <n>, attempt disconnect. (1280)
promon servers screen shows 6 auto servers occupying ports 1025 - 1030.
Connecting to port 1025 directly from the client results hang
Connecting to port 1026 - 1030 is instantaneously
No min and max server ports is configured
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
CAUSE:
The exact cause of this issue is unknown at the time of this writing. Looks like port 1025 has issues receiving request
FIX:
To eliminate port 1025 from server pool, setting -minport parameter to 1026 and start database