Kbase P125528: ProInventory utility fails with error when specifying -logprover parameter
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  17/08/2007 |
|
Status: Unverified
FACT(s) (Environment):
Windows
SYMPTOM(s):
Running ProInventory to collect information on Progress installations
More than 1 Progress version is installed on the PC
Using -logprover parameter to specify which version of Progress to gather information on
ProInventory fails with error
ERROR: Invalid value specified for -logprover. Use a value from the following
list: <List of installed versions>
ProInventory runs if -logprover is not specified but no log files from desired version are present in the resulting zip file
Environment.log, SysInfo.log, Versions.log contain information about all versions installed
SysInfo.log lists the Progress version in the Installed Software section
Versions.log contains an entry similar to:
Found Registry key HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS for version <##.##>
DLC is set to C:\DLC\, but directory is not valid
C:\DLC folder does exist
CAUSE:
DLC folder was not configured correctly during the installation process and an extra back-slash character was added to the install path:
C:\DLC\
This back-slash was used during the tailoring process and included in all Progress paths, resulting in:
C:\DLC\\bin
ProInventory was unable to find this location.
FIX:
Option #1
Reinstall the Progress version with the problem and ensure that the installation path is set correctly, without the trailing back-slash.
Option #2
Manually edit the paths in the Registry to remove the extra back-slash.
WARNING - You should always make a backup of the Registry before any changes.