Kbase P125362: Error 13767 reported in AppServer broker log files in OpenEdge 10.1B
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  03/05/2011 |
|
Status: Verified
SYMPTOM(s):
Error 13767 reported in AppServer broker log files in OpenEdge 10.1B
The ASK major version was missing in the CONNECT request (<exception>). AppServer Keepalive protocol is disabled for this connection. (13767)
The ASK major version was missing in the CONNECT request (com.progress.ubroker.util.ubMsg$TlvFieldNotFoundException: TlvAccessException). AppServer Keepalive protocol is disabled for this connection. (13767)
AppServer agent log file reports "ASK Protocol is disabled."
FACT(s) (Environment):
AppServer logging level is set to "Extended" (level 4)
Clients are running 10.1B or earlier versions of Progress / OpenEdge
OpenEdge 10.1B
All Supported Operating Systems
CAUSE:
The message 13767 is a diagnostic message related to the AppServer Keepalive protocol (ASK).
The ASK protocol is an optional protocol that is initiated by the client when it sends the CONNECT request. This message (13737) in the broker log simply indicates that the client did not request to use ASK protocol when it connected. In 10.1B and earlier versions, the feature is not available on the client side, so the message would appear with any client connection.
This message does NOT indicate a problem of any kind.
FIX:
In 10.1B or earlier, to prevent the message from appearing in the log file, use a logging level of 3 (Verbose), 2 (Basic) or 1 (Error Only).
In 10.1C or later, to prevent the message from appearing in the log file, use a logging level of 2 (Basic) or 1 (Error Only).