Consultor Eletrônico



Kbase P125201: Cannot connect to OpenEdge database from SQL-92 client
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   05/04/2011
Status: Verified

SYMPTOM(s):

Cannot connect to OpenEdge database from SQL-92 client

[DataDirect][ODBC OPENEDGE Wire Protocol driver] [OpenEdge] Broker rejects connection.

Error 8840 appears in the database log file.

Could not fork a SQL server process. (8840)

FACT(s) (Environment):

promon dbname -> R&D-> 1. Status -> 3. Servers shows that the primary and secondary login broker were started for the database.
Database is configured for a primary and secondary login broker.
OpenEdge 10.1B
Windows

CAUSE:

_sqlsrv2.exe is missing from the %DLC%\bin directory. This occurs as result of not choosing to install the SQL Server Engine when installing OpenEdge.

FIX:

Reinstall OpenEdge as complete installation.