Consultor Eletrônico



Kbase P125122: Unable to access workspace when starting OE Architect
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/04/2010
Status: Verified

SYMPTOM(s):

Unable to access workspace when starting OE Architect

Workspace in use or cannot be created, choose a different one.

FACT(s) (Environment):

Windows
OpenEdge 10.x

CAUSE:

The exact cause is unknown at the time of this writing

FIX:

The message "Workspace in use or cannot be created, choose a different one." is displayed because Eclipse considers that the workspace is locked.
It is possible that even though the OE Architect has been closed, there is still activity and the session is still in memory, locking the workspace. Therefore, when restarting OE Architect, this message will be displayed.
To avoid this message, make sure you do not have any Eclipse VM running. If so, exit from it or kill its processes.
In case there is no Eclipse VM running, you can attempt to delete the lock file under <your workspace>/.metadata/.lock.