Consultor Eletrônico



Kbase P125057: Database fails to start under Progress Explorer error 13727
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   7/20/2007
Status: Unverified

FACT(s) (Environment):

OpenEdge 10.0x
OpenEdge 10.1A
OpenEdge 10.1B
Windows

SYMPTOM(s):

database fails to start under Progress Explorer error 13727

Use the 10.1A proutil utility to truncate the BI file. (13727)

2phase commit is not enabled

Bi file was truncated previously using 10.1A executables

re-truncating with the 101dbutils\101a_dbutil dbname -C truncate bi does not solve the problem

database can be started from proenv command line proserve dbname

OpenEdge 10.1B was installed to the same directory as previous installation

previous OpenEdge install was first uninstalled

errors during uninstall that procfg.dll in use

errors during uninstall that environ.dll in use

progress executable using dll's killed through Process Explorer

no pending MicroSoft updates

the server has not been rebooted

CAUSE:

A pre-requisite to a clean install, is that all related Progress executables are not running beforehand. The AdminServer and ubrokers use procfg.dll and environ.dll, which relate to the previously installed version.

FIX:

Stop all related processes running particular to the OpenEdge environment (batch jobs, AdminService, databases etc)
Re-install OpenEdge 10.1B, or alternatively (re)install the latest OpenEdge 10.1B Service Pack