Kbase P125009: Unable to access the SOAP Fault returned by a 3rd-party Web Service in an OpenEdge 10.1x client
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  7/18/2007 |
|
Status: Unverified
FACT(s) (Environment):
OpenEdge 10.1x
All Supported Operating Systems
SYMPTOM(s):
Unable to access the SOAP Fault in an OpenEdge 10.1x client
Error receiving Web Service Response: No message received. (11773)
Accessing a 3rd-party Web Service
CAUSE:
The HTTP status in the SOAP Fault response message is 200 (success). According to the SOAP specification it should be 500 (failure) if the SOAP message contains a SOAP fault.
FIX:
Please contact the Web Service provider in order for them to fix this issue.