Kbase P124948: WebSpeed Broker not displaying status from Progress Explorer.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  7/13/2007 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
OpenEdge Category: Diagnostics
OpenEdge Server Technology Category: AdminServer
OpenEdge Server Technology Category: WebSpeed
OpenEdge Server Technology Category: NameServer
OpenEdge Server Technology Category: AppServer
SYMPTOM(s):
WebSpeed Broker not displaying status from Progress Explorer.
wtbman -i <broker name> -q shows broker alive.
wtbman -i <broker name> -x returns to command line with no error.
WebSpeed Broker log indicates Port in use during failed attempts to start the WebSpeed Broker.
netstat -a shows no listing for the port or name assigned to the WebSpeed Broker.
Reviewed what the last PID for the Webspeed Broker was prior to the port in use messages. Found the process was still running.
CAUSE:
An earlier attempt to start the WebSpeed Broker may have failed.
The java process may have locked the port so that it may not be used by another other process, however the process did not complete its startup phase so is not available for requests.
FIX:
Review the WebSpeed Broker log for messages from the last period the broker was known to be working.
See if the process ID is still in existence. Since this is the WebSpeed Broker the actual process name will be java on Unix and java.exe on Windows.
If the process is still in existence, terminate the process.