Consultor Eletrônico



Kbase P124883: Invalid license file causes SQL-89 ODBC driver to fail.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/28/2010
Status: Unverified

SYMPTOM(s):

Invalid license file causes SQL-89 ODBC driver to fail.

[DataDirect][ODBC Progress OpenEdge Wire Protocol driver]You are not licensed to use this DataDirect Technologies ODBC Driver under the license you have purchased. If you wish to purchase a license for use with this application, then you may use this driver for a period of 15 days, during which time you are required to obtain a license.

Invalid license file causes SQL-89 ODBC driver to fail.

[DataDirect][ODBC Progress OpenEdge Wire Protocol driver]You can order a license for a DataDirect Technologies ODBC Driver for use with this application by calling DataDirect Technologies at 800-876-3101 in North America and +44 (0) 1753-218 930 elsewhere. Thank you for your cooperation. Reason Code: 0200000000000001

File IVODBC.LIC does not exist or is empty

Client process cannot read file IVODBC.LIC due to permission issues

Using evaluation license file IVPG.LIC

Current directory contains IVODBC.LIC or IVPG.LIC from different installation/version

ODBC.INI contains key QEWSD in data source section

Removing the QEWSD key alleviates the issue for 15 days

The QEWSD key in ODBC.INI is re-added automatically after it is removed

FACT(s) (Environment):

Progress 8.x
Progress 9.x
All Supported Operating Systems
ODBC Drivers

CAUSE:

An invalid license file causes the ODBC driver to fail.
This happens in the following cases:
- either an evaluation license was in use (IVPG.LIC) and has expired, or
- the permanent license file IVODBC.LIC is not found by the driver.
The driver will try to find IVPG.LIC and IVODBC.LIC in the SQL89 ODBC driver installation directory or (on Windows) in the global system directories %WINDOWS%/system32. If any of these directories contains an invalid file, an empty file, an expired evaluation license file or a license file from a different/previous installation of the driver, or if the correct file are not readable by the client process due to permission issues, then the driver reverts to "trial mode".

When in trial mode, the driver creates an empty IVODBC.LIC file and creates a key QEWSD in ODBC.INI. The key QEWSD is used to limit the trial period to 15 days. After the trial period has expired, the ODBC driver fails again until either a valid license file can be read and the QEWSD key is manually removed.

FIX:

Ensure that a correct IVODBC.LIC or IVPG.LIC (evaluation) is in use.
If an evaluation license was previously installed and has expired, remove the file IVPG.LIC from the system.
If using a Evaluation driver acquired directly from DataDirect and it has expired:
Contact DataDirect technical support to get a valid license.