Kbase P124798: Java errors generated randomly by Progress Explorer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/11/2010 |
|
Status: Verified
SYMPTOM(s):
java errors generated randomly by Progress Explorer
Progress Explorer open for long period time
com.ms.com.ComFailException: (0x80004005) Unspecified error
at com/progress/vj/mmc/IToolbar.AddBitmap
at com/progress/vj/explorer/ProgressExplorerComponent.updateToolBar2
at com/progress/vj/explorer/ProgressExplorerComponent.updateToolBar
at com/progress/vj/explorer/ProgressExplorerComponent.onSelect
at com/progress/vj/explorer/ProgressExplorerComponent.Notify
FACT(s) (Environment):
OpenEdge 10.1A
OpenEdge 10.1B
Windows
OpenEdge 10.1x
Progress 9.1x
CAUSE:
There are problems with the mmc (microscoft management console) and the adminserver, which the basic error received possibly on a tcp/ip refresh. It cannot add a bitmap to the toolbar. This is the com.ms.ComFailException error which results in a snap-in type error. This usually means an entry in the registry is incorrect or the pointer is corrupt.
Progress Explorer is actually using java 1.2 (or thereabouts) with the .msc .dll (remade per java version of AdminServer for Progress) to make the rmi calls to the java the adminserver is run under. As java 1.6 is in use, the failure is expected.
FIX:
Install the appropriate java version for the Progress AdminServer.
Sun java 1.42 for OpenEdge 10.1A, 10.1B on Windows.