Consultor Eletrônico



Kbase P102546: The AppServer processes stop responding (hangs) under Fathom Management
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   8/28/2007
Status: Verified

FACT(s) (Environment):

Fathom Management 3.0A
Progress 9.1E
OpenEdge 10.x

SYMPTOM(s):

The AppServer processes stop responding (hangs) under Fathom Management

The asbman command stops responding (hangs)

The nsman command works and shows the broker still being registered with the NameServer


The nsman command shows the AppServer broker still being registered with the controlling NS1


Users connected and connecting to an AppServer get 9407 error


Connection failure for host <host_name> port <port> transport <transport_name>. (9407)

AppServer is being trended by Fathom Management

CAUSE:

Bug# OE00113196

CAUSE:

The ubroker is a multi-threaded java process. Specifically, there are threads that handle each client connection, and threads that handle each AppServer agent. To process requests, these threads must interact. The "hang" is caused by a deadlock between the thread that handles the client connection and the thread that handles the agent connection. This can happen when the broker receives a procstats update message from an agent at the same time a client is reserving that same agent. This only occurs under very specific timing considerations, so the problem is very infrequent and difficult to reliably reproduce. The Solution to this problem was to change the internal locking semantics to avoid the condition that caused the deadlock.

FIX:

This issue has been addressed in Progress 9.1E02 and OpenEdge 10.0B03 | 10.1A

Or to work around this problem, disable the monitoring of AppServers from Fathom Management.
In the $DLC/properties/ubroker.properties, for each AppServer:
[UBroker.AS.<name>]
collectStatsData=0