Kbase P124619: Database gives error 1260 and can't be started after power failure on machine.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  6/30/2009 |
|
Status: Verified
SYMPTOM(s):
Database gives error 1260 and can't be started after power failure on machine.
Shared memory in use by another process. (1260)
No <database name>.lk file in database directory.
No _mprosrv processes listed in Task Manager process list.
Several _progres sessions listed in Tash Manager process list.
proutil <database name> -C truncate bi fails with error 1260.
FACT(s) (Environment):
Windows
Progress/OpenEdge Product Family
OpenEdge Category: Database
CAUSE:
One of the _progres sessions hung while accessing the database.
FIX:
1) Identify all _progres sessions which might be attempting to access the database which has generated the 1260 error.
2) Stop all processes which might be attempting to access the database.
3) Attempt either a single user session against the database
or
Attempt to start a server for the database.
At this point the database will begin crash recovery after which it can be shutdown and started thru whatever normal procedures the database is governed by.
If this does not resolve the problem please refer to other trouble shooting options listed in the note below.