Kbase P124446: System Error 881 on bi after running prostrct unlock -extents
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  22/04/2008 |
|
Status: Verified
FACT(s) (Environment):
OpenEdge 10.x
All Supported Operating Systems
SYMPTOM(s):
System Error 881 on bi after running prostrct unlock -extents
Lost, missing or damaged bi files repaired by using prostrct unlock -extents utility
Database fails to start with error 881
SYSTEM ERROR: The before-image file has the wrong cluster size. (881)
SYSTEM ERROR: The broker is exiting unexpectedly, beginning Abnormal Shutdown. (5292)
SYSTEM ERROR: Releasing regular latch. latchId:<latch-num> (5028)
User <num> died holding <num> shared memory locks. (2522)
The replaced bi files are the correct size after running prostrct unlock -extents
CAUSE:
The bi files replaced through the prostrct unlock utility have no bearing on the current database, so starting up immediately runs roll back recovery which fails.
FIX:
Progress recommends the restoration of a database backup in this scenario. Before considering further actions of the workarounds below, please review p24330, "Consequences of using the (-F) option to start the db"
STEPS:
1. After having run prostrct unlock -extents the database needs to forced into (again) as starting up immediately runs roll back recovery. The bi files replaced through the prostrct unlock utility have no bearing on the database.The force option needs to be specified.
$: echo y | proutil dbname -C truncate bi -F
2. Verify that the database can now be started.
3. To validate that the database was not damaged as a result of the prostrct unlock or the forcing into the database, scan the database using the instructions in the Solutions referenced below.