Consultor Eletrônico



Kbase P124426: 10.1B client can't connect to audit-enabled database in previous version
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/22/2008
Status: Verified

FACT(s) (Environment):

All Supported Operating Systems
OpenEdge 10.1B

SYMPTOM(s):

10.1B client can't connect to audit-enabled database in previous version

Client and server are not running the exact same version and service pack

10.1B client is disconnected immediately after logging in to database.

Database is reachable but logs out the user immediately after login.

There is no error message.

Database log file records login logout messages from client

CAUSE:

This is a known issue

FIX:

There are currently two workarounds:
- have the database server run the exact same version and service pack as the client, or
- enable an audit policy for event 10500 (setdbuser) on the database.

There are two ways to enable such an audit policy using the Audit Policy Maintenance Tool from a client session:
- add a policy manually for this event, or
- load the default set of policies from DLC/auditing/policies.xml