Kbase P123840: Admin Server does not start
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  09/09/2008 |
|
Status: Unverified
SYMPTOM(s):
Admin Server does not Start
Log shoes error 7900
Bind failed: (7900)
Bind failed: java.rmi.ConnectException: Connection refused to host and java.net.ConnectException: Connection timed out (7900)
Firewall protecting connections to the server machine
Netstat on the AdminServer port after you try to start shows the status SYN_SENT
FACT(s) (Environment):
OpenEdge 10.x
UNIX
CAUSE:
When Admin server starts, it creates a server socket on the 20931 or any other port is configured to start, and also creates a connection to this port using the hostname specified by the default hostname. The problem is caused when firewall is denying the connection and AdminServer does not start
FIX:
To fix it, follow the steps bellow:
1 - At the bottom of the proadsv script where the command "exec" is stated add following command: -Djava.rmi.server.hostname=<hostname> between the -Djvmstart and -Djava parameters.
Example : Original proadsv script: -Djvmstart.debug=$JVMSTRT_DBGOPT -Djava.command=$JVMEXE
Modified proadsv script: -Djvmstart.debug=$JVMSTRT_DBGOPT -Djava.rmi.server.hostname=localhost -Djava.command=$JVMEXE
By using the hostname localhost admin server will be able to run, but future revision to the ports allowed to go thru the firewall is needed, because the Admin server has to be reachable from other machines if you want to control it using Progress explorer.