Kbase P123802: Restore of backup failing with 13732 error
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  7/20/2007 |
|
Status: Verified
FACT(s) (Environment):
OpenEdge 10.1B
OpenEdge 10.1A
SYMPTOM(s):
Restore of backup failing with 13732 error
This backup of a 32-bit DBKEY database contains BI or TL data.
It cannot be restored by the 64-bit DBKEY codebase. (13732)
Restore being carried out with 10.1B prorest executables
Backup created against OpenEdge 10.1A database
Backup created online with probkup online
Backup created with with probkup -norecover option specified
Backup created with 3rd party OS tools without truncating the bi first
CAUSE:
Before an OpenEdge 10.1A database can be opened in a 10.1B environment, the bi file must first be truncated using 10.1A executables.
If an offline backup had been taken, it would have restored using the 10.1B prorest as the bi would have already been truncated as part of the initial process. An offline probkup will first truncate the bi, unless the -norecover is specified. An online probkup delays the truncate process to when the backup is restored with the prorest utility.
Because probkup online doesn't truncate the bi, 10.1B can't correctly restore the backup created with probkup online under 10.1A. The same error behaviour occurs if the -norecover option is specified for the backup as well.
FIX:
Use the 101A executables provided in the 10.1B install directory (%DLC%\bin\101dbutils\) to restore the backup then truncate the bi file. In the case of an OS backup, only the bi truncation is required:
1) %DLC%\bin\101dbutils\101a_dbutil prorest dbname backupname
2) %DLC%\bin\101dbutils\101a_dbutil dbname -C truncate bi
3) start the database in the 10.1B environment.