Consultor Eletrônico



Kbase P123607: Progress OpenEdge 10.1B driver is not available on NetSetup client
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/14/2010
Status: Verified

SYMPTOM(s):

Progress OpenEdge 10.1B driver is not available on NetSetup client

NetSetup installation will not add the SQL Client Access

ODBC driver is not installed with NetSetup

No errors reported during NetSetup

Progress OpenEdge 10.1B driver is not available on NetSetup client

The PGOE1022.DLL is present under %DLC%/bin directory on the Server machine

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
OpenEdge 10.1B
Progress OpenEdge 10.1B driver

CAUSE:

Bug# OE00149956

CAUSE:

ODBC driver is not available through the ODBC Data Source Administrator Interface on Windows after NetSetUp installation, because the NetSetup was not properly programmed to install the ODBC driver files and setup the registry of the system where NetSetup was invoked.

FIX:

Upgrade to OpenEdge 10.1C where the netsetup installer now calls a subinstall that performs the SQL driver install


To make the ODBC driver available on the client machine without reinstalling:

Option #1 - with OpenEdge 10.1C and later

1) On the client machine, access <DLC>\install\ODBC via the mapped driver or UNC path used to access netsetup.
2) Execute sql-odbc-setup.exe


Option #2
Manually add the registry keys which will make the driver accessible.

1) Copy the lines below, between <begin> and <end> into a file as xx.reg.
2) Edit the path to the Progress installation (eg: Q:\\progress\\oe101b = <mapped drive>:\\<value of %DLC%>. The driver will then be accessible. The double \\ marks are correct for the "Driver" and "Setup" lines, do not change this for the import, only change the drive letter and directory names.
3) Edit the Driver Name to match the version of Progress 10.1x being run.
4) Exclude the <begin> and <end> lines if they were copied into the xx.reg file.
5) Import the xx.reg into the registry via regedit.

Sample file for Release 10.1x if using a mapped drive:

<start>
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Progress OpenEdge 10.1B driver]
"APILevel"="1"
"ConnectFunctions"="YYY"
"CPTimeout"="60"
"Driver"="Q:\\progress\\oe101b\\bin\\pgoe1022.dll"
"DriverODBCVer"="5.1"
"FileUsage"="0"
"Setup"="Q:\\progress\\oe101b\\bin\\pgoe1022.dll"
"SQLLevel"="1"
"UsageCount"="1"
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers]
"Progress OpenEdge 10.1B driver"="Installed"
<end>

Sample file for Release 10.1x if using a UNC path:

<start>
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Progress OpenEdge 10.1B driver]
"APILevel"="1"
"ConnectFunctions"="YYY"
"CPTimeout"="60"
"Driver"="\\\\hostname\\dlc101\\bin\\pgoe1022.dll"
"DriverODBCVer"="5.1"
"FileUsage"="0"
"Setup"="\\\\hostname\\dlc101\\bin\\pgoe1022.dll"
"SQLLevel"="1"
"UsageCount"="1"
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers]
"Progress OpenEdge 10.1B driver"="Installed"
<end>