Consultor Eletrônico



Kbase P123529: OpenEdge Secure Socket connection fails with error 9318
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   28/03/2008
Status: Unverified

FACT(s) (Environment):

OpenEdge 10.1x
All Supported Operating Systems

SYMPTOM(s):

OpenEdge Secure Socket connection fails to connect using HTTPS

Using ABL statement:

CONNECT "-ssl -H <HTTPS URL> -S <port>"

Secure Socket Layer (SSL) failure. error code <err_number>: <ssl_error_message> (9318)

Secure Socket Layer (SSL) failure. error code -54: unable to get local issuer certificate <Certificate Name> from <DLC>\certs (9318)

Socket can be accessed via Web Browser and certificate is used with no errors

CAUSE:

Root CA has not been imported to OpenEdge

FIX:

1 - Go to Control Panel -> Internet Options -> Content folder -> "Certificates" button ->Trusted Root certification Authorities -> Choose required certificate and click on "Export" button.

2 - Export as DER encoded binary X.509 (.CER)

3 - Import to OpenEdge using the following command from PROENV:

certutil -format DER -import exportedfilename.cer