Consultor Eletrônico



Kbase P123426: AdminServer no longer starts after installing Service Pack or TFix for remote monitoring upgrade
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   1/22/2008
Status: Verified

FACT(s) (Environment):

OpenEdge Management 3.1B
OpenEdge 10.1B
OpenEdge 10.1A
OpenEdge 10.0B
Progress 9.1E

SYMPTOM(s):

AdminServer no longer starts after installing Service Pack for remote monitoring upgrade

Unable to start AdminServer after installing a TFix for remote monitoring upgrade

All processes were stopped before applied SP or TFix

Service pack or TFix have been correctly installed

[AdminServer] Instantiating management framework container...

Prior the installation AdminServer has been configured for a remote monitoring

full admserv.log file reads:

[AdminServer] Instantiating management framework container...
[AdminServer] * Instantiation of management framework container timed out after 360 seconds
[AdminServer] Failed to instantiate the management framework container.
[AdminServer] Failed to load the management framework container.
[AdminServer] Before restarting,
[AdminServer] 1. Ensure that remote Fathom AdminServer is running, or
[AdminServer] 2. Use '-nofathom' start up option

CAUSE:

Installation of the SP and/or the TFix is not sufficient to complete the configuration for remote monitoring.
Additional steps are required and are listed in the Fix below.

FIX:

There are separate steps necessary to complete the fix for remote monitoring depending on whether the problem is encountered on the OpenEdge Machine or the remotely monitored machine.

[ Steps to follow when hitting the problem on the OpenEdge Management machine ]

1) stop AdminServer and all 10.1B01/3.1B01 processes
2) proenv -> "fmconfig -disable"
3) delete MFConfigurationElements.xsd from WRKDIR (working directory)
4) delete DLC/properties/management.properties
5) run "FATHOM/SonicMQ/uninstall.bat" or "FATHOM/SonicMQ/uninstall.sh -console" (based on Windows/Unix platform)
6) delete FATHOM/SonicMQ and FATHOM/sonic_setup directories + delete FATHOM/SonicMQ.ini
7) proenv -> "fmconfig -enable"
8) start AdminServer

[ Steps to follow when hitting the problem on the remote 10.1B01/10.1A0221/10.0B0534/9.1E0420 installation ]

1) stop all Progress/OpenEdge processes related to the installation
2) proenv -> "fmconfig -disable"
3) delete following files in WRKDIR: Fathom1.*.cache folder, MFConfigurationElements.xsd, *.import
4) delete following files in DLC: MFConfigurationElements.xsd, container.xml
5) delete DLC/properties/management.properties
6) fmconfig -update -host <oemhost> (this assumes the OE Management has already been upgraded to 3.1B01/10.1B01 and it is running).
7) start the remote AdminServer.