Consultor Eletrônico



Kbase P123241: Getting errors 735 and 778 from client application when running Progress when client executable file
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   17/02/2009
Status: Verified

SYMPTOM(s):

Getting errors 735 and 778 from client application when running Progress when client executable files reside on Windows 2003 file server.

No errors when running Progress client if executable files reside on Windows 2000 file server.

** Incomplete write when writing to the server. (735)

Error <read/writing> socket, ret=<n>, errno=<n>. (778)

File server using Teaming software from BroadCom to utilize full bandwidth of dual network cards.

Removing the teaming software or upgrading the NIC remedies the problem.

Old NIC driver is Broadcom 8.48.0.0 which was upgraded to 10.24.0.0.

Teaming software version is 6.0.9.0 from Broadcom.

FACT(s) (Environment):

Progress/OpenEdge Versions
OpenEdge Category: Language (4GL/ABL)
Windows Server 2003

CAUSE:

The combination of the Broadcom Teaming Software and Windows 2003 file server seems to cause an instability in the network connectivity to the Windows 2003 file server.

FIX:

One workaround to this problem is to use Windows 2000 as the operating system of the file server.
Another workaround is to disable the teaming software.
Another workaround is to upgrade the network card.