Consultor Eletrônico



Kbase P122999: AdminServer won't start from Windows Services or proadsv.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   23/06/2009
Status: Verified

SYMPTOM(s):

AdminServer won't start from Windows Services or proadsv.

No error messages listed from command line.

No error messages in admserv.log file.

Copied all environment variable settings from proadsv.bat script into proenv session.

Used the variables from the USEREG section of proadsv.bat.

Modified string which launches the AdminServer to remove the -o stderror and -m silent.

Error generated after using modified command string to start AdminServer:
Error parsing argument: (-DWorkDir=@{WorkPath})
Error starting JVM, error 22.
The device does not recognize the command.
completed.

FACT(s) (Environment):

Windows
Progress 9.1x
OpenEdge 10.x

CAUSE:

Windows Registry key for WorkPath is missing.

FIX:

Check to make sure that the WorkPath value is set in the registry for the respective version.
Highlight the following key:
HKEY_CURRENT_USER\Software\PSC\PROGRESS\<version>
There should be a WorkPath string value defined.
If there is no string value named WorkPath defined, create one, and set its value to the working directory for the database or application.

Repeat the same process for the following key:
HKEY_LOCAL_MACHINE\Software\PSC\PROGRESS\<version>