Consultor Eletrônico



Kbase P122192: Unable to start the OpenEdge debugger on Citrix server
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/29/2007
Status: Verified

FACT(s) (Environment):

OpenEdge 10.x
Citrix MetaFrame (for Windows 2000 Terminal Server)

SYMPTOM(s):

Unable to start the OpenEdge debugger on Citrix

Trying to start the debugger on a Citrix server results in error 11724.

Debugger fails to start from Editor session with the DEBUGGER:INITIATE() method.

The Progress 4GL is not enabled for debugging. Use the proDebugEnable
tool to enable debugging and set debugger Enabled to 1 for Appservers.
(11724)

prodebugEnable has been performed.

CAUSE:

This is a permissions problem. When Progress is installed there are two things that happen:

1. The registry key for debugging is created and disabled. This is why prodebugEnable is required.
2. It then sets the access control list for _debugEnable.exe, giving full access to the user who installs Progress and all other users in the Administrator group on that machine.

FIX:

To resolve this problem do one of the following:

1. Add the user trying to start the debugger to the Adminstrator security group.
2. Modify the permissions of the <install>/bin/_debugEnable.exe file. Give the user trying to start the debugger FULL access to this file. This is the same as the installation user and the Administrator group.