Kbase P101146: Cannot connect to a Progress 9 database and an OpenEdge 10 database via ODBC in the same session
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  28/04/2010 |
|
Status: Verified
SYMPTOM(s):
Attempting to connect to a Progress 9 database and an OpenEdge 10 database via ODBC
Trying to access both databases in the same session
Connection to first database succeeds
Connection to second database fails
ODBC error when Progress 9 database is the second connection:
[DataDirect-Technologies][ODBC PROGRESS driver][PROGRESS]Server did not respond
ODBC error when OpenEdge 10 database is the second connection:
[DataDirect][ODBC OPENEDGE driver][OPENEDGE]No Data
Each version of Progress/OpenEdge refers to its own copy of PROCLI92.DLL (i.e. the version located in DLC\Bin for that particular installation)
Connection to second database succeeds once the first database has been disconnected
Using third-party tool such as Crystal Reports, Excel or WinSQL
Data can be imported and refreshed in individual Microsoft Excel worksheets
Microsoft Excel only generates ODBC error if attempting to "Refresh All" worksheets
FACT(s) (Environment):
Progress 9.1D
Progress 9.1E
OpenEdge 10.0x
MERANT 3.60 32-BIT Progress SQL-92
DataDirect 4.1 32-Bit Progress SQL92 9.1D
DataDirect 4.20 32-Bit OpenEdge SQL92 10.0A
DataDirect 4.20 32-Bit OpenEdge SQL92 10.0B
Using a OpenEdge client verion 10.0x
CAUSE:
Bug# OE00113586
CAUSE:
The main ODBC driver .DLL in both Progress 9 and OpenEdge 10 has a dependency to the file PROCLI92.DLL. PROCLI92.DLL has the same name in both Progress 9 and OpenEdge 10 but has no version number. Once the first ODBC connection is established, PROCLI92.DLL is loaded into memory. When the second ODBC connection is attempted, the version of PROCLI92.DLL that is cached in memory is used rather than the correct version in DLC\Bin. This causes the connection to fail.
FIX:
Upgrade at least one client to OpenEdge 10.1x (10.1A or 10.1B) or later.