Kbase P121648: Uninstall 10.x removes PROGRESS\<version> registry for other installs
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  8/31/2010 |
|
Status: Verified
SYMPTOM(s):
Uninstall 10.x removes registry for other installs
Uninstalling one OpenEdge version affects co-existing Progress installations
Adminserver fails to start after uninstalling another OpenEdge version
HKLM\Software\PSC\Progress\<version> are missing
FACT(s) (Environment):
Windows
OpenEdge 10.0x
OpenEdge 10.1A
Progress 9.1x
CAUSE:
The first install's uninstall removes the HKLM\Software\PSC\PROGRESS\<version> key and then the PROGRESS key, even though there may be other keys under it.
CAUSE:
Bug# OE00129153
FIX:
This issue has been addressed in the uninstall routine of OpenEdge 10.1B.
1. Since a fix cannot be put in place for products that have already been deployed or in a Service Pack, the suggested workaround is to export the HKLM\Software\PSC\Progress\<version> keys before uninstalling and then to import these after the uninstall has completed.
For example:
HKLM\Software\PSC\Progress\10.1A
HKLM\Software\PSC\Progress\10.0B
HKLM\Software\PSC\Progress\9.1E
2. If the uninstall has already completed and the registry keys were not backed up, a reinstall of the affected version is necesary.