Consultor Eletrônico



Kbase P121504: AdminService shows as Started in Windows Services but Progress Explorer fails with error 8336
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   01/03/2010
Status: Verified

SYMPTOM(s):

AdminService is shown as Started

Progress Explorer connection fails with error 8336

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

PROADSV -QUERY returns:

AdminServer not alive. (8543)

No java.exe processes are running

No entry for startup attempt exists in admserv.log

FileMon log displays following entries:

5791 HH:MM:SS AM java.exe:<PID> CREATE <Path>\WRK\ads0.exp ACCESS DENIED NT_AUTHORITY\SYSTEM
12620 HH:MM:SS AM java.exe:<PID> OPEN <Path>\WRK\admserv.log ACCESS DENIED NT_AUTHORITY\SYSTEM

Progress Explorer can connect when AdminService is started manually using PROADSV -START

FACT(s) (Environment):

Starting AdminService from Windows Services
AdminService is started by the Local System Account
Windows
OpenEdge 10.x
Progress 9.x

CAUSE:

ADMSRVC.EXE has executed successfully so the Service appears to be running. However, the Local System account does not have sufficient permissions on the working directory. This prevent the java.exe process from writing to its log files, resulting in a startup failure.

FIX:

Grant Full permissions on the Progress working directory to Everyone