Kbase P120748: Fathom Management Agent is starting with database even when is not set to automatically start after
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  29/10/2007 |
|
Status: Verified
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.1A02 Service Pack
SYMPTOM(s):
Fathom Management Agent is starting with database even when is not set to automatically start
Fathom Management is not licensed
Starting database using Progress Explorer
"Autostart Monitoring Agent" is checked off
A user Db_Agent is connected to the database
database log file shows FMAGENT registered with Admin Server
database log file shows FMAGENT assigned user number
Database is started via Progress Explorer Tool
database started using proserve command does not start the fathom agent
CHANGE:
Applied 10.1A02 Service Pack
CAUSE:
Bug# OE00134067
CAUSE:
This issue is caused by removal of support for the database connection adapter (DBCA) license
FIX:
Upgrade to 10.1B where this issue has been addressed.
To Workaround this issue if upgrading is not possible:
1.) The Agent [FMAGENT] can be stopped from starting automatically the next time the database is started by commenting out the section [Plugin.DatabaseAgent] within %DLC%\properties\AdminServerPlugins.properties file
2.) Although the Agent will not affect the operation of the database and can effectively be ignored in this environment, the Agent can be disconnected from the database by using promon to disconnect the FMagent.
1. promon <dbname>
2. Select menu item 1 (User Control)
Select menu item 1 (Display all entries)
Look for TYPE = FMAGENT and record the USR number assigned
Alternatively, parse the database log file for current user number assigned to the FMAGENT.
3. Select menu item 8 (Shut Down Database)
Select menu item 1 (Disconnect a user)
Enter user number for the fmagent