Kbase P120521: Error 8619 starting a database with Progress Explorer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  31/12/2008 |
|
Status: Verified
SYMPTOM(s):
Error 8619 starting a database with Progress Explorer
Database fails to start with dbman
Database doesn't start under the AdminService
** This process terminated with exit code 1. (8619)
FACT(s) (Environment):
Windows XP
Windows 2003
Progress 9.1x
OpenEdge 10.x
CAUSE:
The error message 8619 is a system error message that indicates when the PROGRESS database server was started in multi-user mode, the server process failed to start successfully and terminated with the named exit code. Error code 1 is very generic and means that a failure occurred in the broker, ie a fail error condition not the reason for failure.
In the Windows XP SP2 and Windows 2003 SP1 environment, this has been found to be due to the new Data Execution Prevention (DEP) security that has been added. When the DEP setting is set to "turn on DEP for all programs and services except those I select." The Progress envronment is essentially prevented from initialising.
FIX:
Right click My Computer>>Properties>>Advanced>>Performance Settings>>choose the DEP tab
- "turn on DEP for essential Windows programs and services only"
or
- "turn on DEP for all programs and services except those I select."
Would mean refining the list to all the Progress and related executables in use, for example;
<Progress Install Directory>/jdk/bin/java.exe # for the AdminService
mproserve.exe # for database server
prowin32.exe # for GUI clients